Configuring
Etherchannels
Objective; Configure an Etherchannel between switch1 and switch 2.
What is an Ether channel?
1.
An EtherChannel allows you to bundle up to 8 Fast Ethernet
or Gigabit Ethernet links into a single logical link.
2.
Single Spanning tree instance treats Port Channel as single
interface
TYPES OF ETHERCHANNELS
1.
MANUAL
configuration - Turn Etherchannel on
2.
Automatic
Configuration - Using PAgP or LACP
EtherChannel Modes
|
|
Mode
|
|
on
|
Forces the
interface into an EtherChannel without PAgP or LACP. With the on mode,
a usable EtherChannel exists only when an interface group in
the on mode is connected to another interface group in
the on mode.
|
Desirable
(PAGP)
|
Places an interface
into an active negotiating state, in which the interface starts negotiations
with other interfaces by sending PAgP packets.
|
Auto
(PAGP)
|
Places an interface
into a passive negotiating state, in which the interface responds to PAgP
packets it receives but does not start PAgP packet negotiation. This setting
minimizes the transmission of PAgP packets.
|
Active (LACP)
|
|
Passive
(LACP)
|
Places an interface
into a passive negotiating state, in which the interface responds to LACP
packets that it receives, but does not start LACP packet negotiation. This
setting minimizes the transmission of LACP packets.
|
The Port Aggregation Protocol (PAgP) and Link Aggregation
Control Protocol (LACP) facilitate the automatic creation of EtherChannels by
exchanging packets between Ethernet interfaces. PAgP is a Cisco-proprietary
protocol that can be run only on Cisco switches and on those switches licensed
by licensed vendors to support PAgP. LACP is defined in IEEE 802.3AD and allows
Cisco switches to manage Ethernet channels between switches that conform to the
802.3AD protocol.
By using one of these protocols, a switch
learns the identity of partners capable of supporting either PAgP or LACP and
learns the capabilities of each interface. It then dynamically groups similarly
configured interfaces into a single logical link (channel or aggregate port);
these interfaces are grouped based on hardware, administrative, and port
parameter constraints. For example, PAgP groups the interfaces with the same
speed, duplex mode, native VLAN, VLAN range, and trunking status and type.
After grouping the links into an EtherChannel, PAgP adds the group to the
spanning tree as a single switch port.
SW2 Configuration
|
Protocol
|
Trunk formed or
not?
|
|
ON
|
ON
|
NONE
|
YES
|
ON
|
AUTO
|
NONE
|
NO
|
ON
|
Desirable
|
NONE
|
NO
|
ON
|
Passive
|
NONE
|
NO
|
ON
|
Active
|
NONE
|
NO
|
Desirable
|
Desirable
|
PAgP
|
YES
|
Desirable
|
AUTO
|
PAgP
|
YES
|
AUTO
|
AUTO
|
NONE
|
NO
|
ACTIVE
|
ACTIVE
|
LACP
|
YES
|
ACTIVE
|
PASSIVE
|
LACP
|
YES
|
PASSIVE
|
PASSIVE
|
NONE
|
NO
|
ETHERCHANNEL ON -LAB Tasks;
1.
Configure FE0/13 and FE 0/14 on SW1 as channel group 1 mode
on
2.
Configure FE0/13 and FE 0/14 on SW2 as channel group 1 mode
on
Verification commands;
Ping R1 to R2 and R2 to R1
Show etherchannel summary
Show interface port-channel 1
show interface port-channel1 switchport
Show interfaces trunk
Final Configurations
SW1:
interface
FastEthernet0/13
channel-group 1
mode on
!
interface
FastEthernet0/14
channel-group 1
mode on
!
interface
Port-channel1
switchport mode
dynamic desirable
SW2:
interface
FastEthernet0/13
channel-group 1
mode on
!
interface
FastEthernet0/14
channel-group 1
mode on
!
interface
Port-channel1
switchport mode
dynamic desirable
ETHERCHANNEL PAGP-LAB
PAGP Final Configuration;
SW1:
interface FastEthernet0/13
channel-group 1 mode desirable
!
interface FastEthernet0/14
channel-group 1 mode desirable
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
SW2:
interface FastEthernet0/13
channel-group 1 mode auto
!
interface FastEthernet0/14
channel-group 1 mode auto
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
ETHERCHANNEL LACP-LAB
Final Configurations;
SW1:
interface FastEthernet0/13
channel-group 1 mode active
!
interface FastEthernet0/14
channel-group 1 mode active
!
interface Port-channel1
switchport mode dynamic desirable
SW2:
interface FastEthernet0/13
channel-group 1 mode passive
!
interface FastEthernet0/14
channel-group 1 mode passive
!
interface Port-channel1
switchport mode dynamic desirable
No comments:
Post a Comment